Issue #16263 has been updated by MSP-Greg (Greg L).


Fix for the test/optparse/test_did_you_mean.rb issue:

https://github.com/ruby/ruby/pull/2581

----------------------------------------
Bug #16263: test-all & did_you_mean - intermitent failures ?
https://bugs.ruby-lang.org/issues/16263#change-82195

* Author: MSP-Greg (Greg L)
* Status: Open
* Priority: Normal
* Assignee: 
* Target version: 
* ruby -v: ruby 2.7.0dev (2019-10-18T18:03:54Z master 5c81e19b19) [x64-mingw32]
* Backport: 2.5: UNKNOWN, 2.6: UNKNOWN
----------------------------------------
If did_you_mean is loaded, the following test failure may occur:

TestException#test_nomethod_error_new_receiver [/ruby/test/ruby/test_exception.rb:999]:
<["Message", :foo, #<Object:0x00000000070f5aa8>]> expected but was
<["Message\n" + "Did you mean?  for", :foo, #<Object:0x00000000070f5aa8>]>.

I run test-all parallel with retry, but some CI may not.  Without the retry, the above test may intermittently fail.

Also, in test/optparse/test_did_you_mean.rb, there are three tests that use a regex:
```
Did you mean\?\s+baz\s+bar
```
I needed to change it to
```
Did you mean\?\s+bar\s+baz
```
for the three tests to pass.  I've never run into that kind of thing with Windows vs other OS's, so one might wonder if the tests are really running??

See https://github.com/ruby/ruby/blob/5c81e19b196e940b3233781b7ef0c5bfcbdee4f5/test/optparse/test_did_you_mean.rb#L29-L47

Anyway, one could spawn Ruby for the three tests so the loading of did_you_mean is isolated, seems like a lot of work...



-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>