Issue #16185 has been updated by Reshma (Reshma Kumar).


I couldn't resolve this issue. Any updates?

----------------------------------------
Bug #16185: testcase fails for 64bit
https://bugs.ruby-lang.org/issues/16185#change-81815

* Author: Reshma (Reshma Kumar)
* Status: Open
* Priority: Normal
* Assignee: kanemoto (Yutaka Kanemoto)
* Target version: 
* ruby -v: 2.6.3
* Backport: 2.5: UNKNOWN, 2.6: UNKNOWN
----------------------------------------
We are building ruby 2.6.3(both 32 and 64bit) on AIX 6.1.
The build options used for 64bit build are:-
export LDFLAGS="-L/opt/freeware/lib64 -L/opt/freeware/lib -Wl,-blibpath:/opt/freeware/lib64:/usr/lib:/lib"
and for 32bit build are:-
export LDFLAGS="-L/opt/freeware/lib -Wl,-blibpath:/opt/freeware/lib:/usr/lib:/lib -Wl,-bmaxdata:0x80000000"

The testcase fails with the following error for 64bit whereas it passes for 32bit

$ ./miniruby -I./lib -I. -I.ext/common  ./tool/runruby.rb --extout=.ext  -- --disable-gems "./basictest/runner.rb" --run-opt=--disable-gems
/home/buildusr/rpmbuild/BUILD/ruby-2.6.3/64bit/basictest/test.rb:system \exec(): 0509-036 Cannot load program sh because of the following errors:
        0509-150   Dependent module /home/buildusr/rpmbuild/BUILD/ruby-2.6.3/64bit/libruby.so.2.6.3 could not be loaded.
        0509-022 Cannot load module /home/buildusr/rpmbuild/BUILD/ruby-2.6.3/64bit/libruby.so.2.6.3.
        0509-026 System error: Cannot run a file that does not have a valid format.                                                                                        F|exec(): 0509-036 Cannot load program sh because of the following errors:
        0509-150   Dependent module /home/buildusr/rpmbuild/BUILD/ruby-2.6.3/64bit/libruby.so.2.6.3 could not be loaded.
        0509-022 Cannot load module /home/buildusr/rpmbuild/BUILD/ruby-2.6.3/64bit/libruby.so.2.6.3.
        0509-026 System error: Cannot run a file that does not have a valid format.                                                                                        F|Traceback (most recent call last):
        1: from /home/buildusr/rpmbuild/BUILD/ruby-2.6.3/64bit/basictest/test.rb:2022:in `<main>'
/home/buildusr/rpmbuild/BUILD/ruby-2.6.3/64bit/basictest/test.rb:2022:in `unlink': No such file or directory @ apply2files - script_tmp.13762634.bak (Errno::ENOENT)

not ok system 2 -- /home/buildusr/rpmbuild/BUILD/ruby-2.6.3/64bit/basictest/test.rb:1975:in `<main>'
not ok system 8 -- /home/buildusr/rpmbuild/BUILD/ruby-2.6.3/64bit/basictest/test.rb:2019:in `<main>'
test failed


Any idea what is the issue?



-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>