Issue #16170 has been updated by mame (Yusuke Endoh).


FYI: How many times the gems is required from all latest public gems by using [gem-codesearch](https://github.com/akr/gem-codesearch).

```
$ csearch "require .mutex_m.$" | wc -l
199
$ csearch "require .scanf.$" | wc -l
119
$ csearch "require .thwait.$" | wc -l
84
$ csearch "require .sync.$" | wc -l
83
$ csearch "require .tracer.$" | wc -l
77
$ csearch "require .shell.$" | wc -l
72
$ csearch "require .cmath.$" | wc -l
22
```

----------------------------------------
Feature #16170: Remove the unmaintained libraries from Ruby 2.7
https://bugs.ruby-lang.org/issues/16170#change-81593

* Author: hsbt (Hiroshi SHIBATA)
* Status: Assigned
* Priority: Normal
* Assignee: hsbt (Hiroshi SHIBATA)
* Target version: 
----------------------------------------
I'm working to extract standard libraries to rubygems in recent years. So, the standard libraries will be promoted the default gems or bundled gems.

But I suggest removing some of the unmaintained libraries without default/bundled gems.

These are here:

* cmath
* mutex_m
* scanf
* shell
* sync
* thwait
* tracer

We should reduce the maintenance cost for them.



-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>