Issue #15769 has been updated by usa (Usaku NAKAMURA).

Backport changed from 2.4: REQUIRED, 2.5: REQUIRED, 2.6: DONE to 2.4: REQUIRED, 2.5: DONE, 2.6: DONE

ruby_2_5 r67717 merged revision(s) 67563.

----------------------------------------
Bug #15769: Backport r67563: SNI is not enabled in Net::IMAP
https://bugs.ruby-lang.org/issues/15769#change-80303

* Author: knu (Akinori MUSHA)
* Status: Closed
* Priority: Normal
* Assignee: naruse (Yui NARUSE)
* Target version: 
* ruby -v: 
* Backport: 2.4: REQUIRED, 2.5: DONE, 2.6: DONE
----------------------------------------
Net::IMAP should enable SNI for it to be able to connect to SNI enabled servers like imap.gmail.com. (Gmail started to require SNI last year)

This problem is exposed when the underlying SSL library supports TLSv1.3, such as OpenSSL >=1.1.x.



-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>