Issue #14614 has been updated by jeremyevans0 (Jeremy Evans).

Status changed from Open to Feedback

The error indicates `executable host ruby is required. use --with-baseruby option.`  Does the error happen if you use the `--with-baseruby` option when configuring?

----------------------------------------
Bug #14614: Error when running `make update-gems`
https://bugs.ruby-lang.org/issues/14614#change-78747

* Author: vitalkanev (Vitaliy Kanev)
* Status: Feedback
* Priority: Normal
* Assignee: 
* Target version: 
* ruby -v: ruby 2.5.0p0 (2017-12-25 revision 61468) [x86_64-linux]
* Backport: 2.3: UNKNOWN, 2.4: UNKNOWN, 2.5: UNKNOWN
----------------------------------------
~~~
vitalkanev@vitalkanev-HP-Mate:~/power/ruby/ruby-2.5.0$ make update-gems
Downloading bundled gem files...
executable host ruby is required. use --with-baseruby option.
# Next line might look-like that:
uncommon.mk:1139: error while running recipe for "update-gems" target
make: *** [update-gems] Error 1
~~~

This error can be seen _only_ when compiling Ruby from the source
code tarball.

gcc version (included in `build-essentials` package):

~~~
gcc (Ubuntu 7.2.0-8ubuntu3.2) 7.2.0
Copyright (C) 2017 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
~~~

`make` version: `GNU Make 4.1`



-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>