Issue #15907 has been updated by MSP-Greg (Greg L).


Hiroshi,

Good evening.  A ruby-loco CRON job just happened to run on 3776c48cf4, and it passed.

Thank you, and sorry for the delay, I recently woke up.

JFYI, a while ago I added CLI output to ruby-loco CI, but I didn't add code to fail a build on CLI errors.  Hence, CLI could be broken, but ruby-loco would pass.  Not good for all the repos using it for CI...

I've now added CI code to fail a build on CLI failure.  Thanks again, Greg

----------------------------------------
Bug #15907: gem bin stub commands are failing
https://bugs.ruby-lang.org/issues/15907#change-78402

* Author: MSP-Greg (Greg L)
* Status: Assigned
* Priority: Normal
* Assignee: hsbt (Hiroshi SHIBATA)
* Target version: 
* ruby -v: ruby 2.7.0dev (2019-06-08 master 1696f80f40) [x64-mingw32]
* Backport: 2.4: UNKNOWN, 2.5: UNKNOWN, 2.6: UNKNOWN
----------------------------------------
Commands like
```ruby
bundle version
irb  --version
rake --version
rdoc --version
```
are failing. All failure are something similar to:
```
bundle : lib/ruby/2.7.0/rubygems/core_ext/kernel_gem.rb:64:in `synchronize': deadlock; recursive locking (ThreadError)
from lib/ruby/2.7.0/rubygems/core_ext/kernel_gem.rb:64:in `gem'
from lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:42:in `require'
```

I think this bug has been exposed by "require rubygems/package where used" b76630f73e, maybe a circular loading issue?






-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>