On 10/19/06, dblack / wobblini.net <dblack / wobblini.net> wrote:

> On Thu, 19 Oct 2006, Yukihiro Matsumoto wrote:

> > Hmm, maybe the name Enumerator does not make you feel like it's a
> > collection.  What if Enumerator is renamed to some other name, for
> > example, DelayedCollection or something?

Yes!  Excellent!  That's the way I think of it, anyway.

> Interesting.  That might indeed make it feel more like something I was
> asking for.  I still feel, though, like the plain plural "things"
> method suggests an actually collection much, much more than it
> suggests anything else.  But I'll ponder it some more.

As one begin to use the "functional" interfaces more and more, I think
one gets used to plurals meaning any kind of collection, be it an
array or a lazy list/delayed collection/whatchamacallit.

  nikolai