Issue #15826 has been reported by extrowerk (Zolt=E1n Mizsei).

----------------------------------------
Bug #15826: Haiku LIBC_SO and LIBM_SO support for test/fiddle/helper.rb
https://bugs.ruby-lang.org/issues/15826

* Author: extrowerk (Zolt=E1n Mizsei)
* Status: Open
* Priority: Normal
* Assignee: =

* Target version: =

* ruby -v: ruby 2.6.3p62 (2019-04-16 revision 67580) [x86_64-haiku]
* Backport: 2.4: UNKNOWN, 2.5: UNKNOWN, 2.6: UNKNOWN
----------------------------------------
This is required for the tests.

Haiku comes currently in 2 different flavour: 32 and 64 bit.
64 bit have only one toolchain, so it is easy, but 32 bit comes with 2 diff=
erent (GCC2 primary and GCC7 secondary). Ruby built with GCC7 on Haiku, so =
it needs to pick the secondary arch libroot.so.
libroot.so is a complex lib which provides the libm and libc functionality,=
 and probably much more.

---Files--------------------------------
ruby_test_fix.patch (692 Bytes)


-- =

https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=3Dunsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>