Issue #15754 has been reported by MSP-Greg (Greg L).

----------------------------------------
Bug #15754: MinGW build/compile failure with Ruby 2.5.5, but 2.6.2 & trunk ok
https://bugs.ruby-lang.org/issues/15754

* Author: MSP-Greg (Greg L)
* Status: Open
* Priority: Normal
* Assignee: 
* Target version: 
* ruby -v: 
* Backport: 2.4: UNKNOWN, 2.5: UNKNOWN, 2.6: UNKNOWN
----------------------------------------
As many of you may recall, I'm not a c type, especially regarding build errors.  Recently tried to build 2.5.5 locally, and I get errors similar to the below.  I do not have any errors using the same build code (ruby-loco) when building 2.6.2 or trunk.

Any help/suggestions would be appreciated...  Thanks, Greg

Attached larger log with config info.

```
../ruby/array.c:2197:52: error: expected ')' before 'PRI_LL_PREFIX'
      rb_raise(rb_eTypeError, "wrong element type %"PRIsVALUE" at %ld (expected array)",
                                                    ^
                                                    )
../ruby/array.c: In function 'rb_ary_bsearch_index':
../ruby/array.c:2676:53: error: expected ')' before 'PRI_LL_PREFIX'
      rb_raise(rb_eTypeError, "wrong argument type %"PRIsVALUE
                                                     ^
                                                     )
../ruby/array.c: In function 'take_items':
../ruby/array.c:3318:49: error: expected ')' before 'PRI_LL_PREFIX'
  rb_raise(rb_eTypeError, "wrong argument type %"PRIsVALUE" (must respond to :each)",
                                                 ^
                                                 )
```


---Files--------------------------------
ruby_2.5.5_build_errors_no_j.txt (6.32 KB)


-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>