Issue #4475 has been updated by sos4nt (Stefan Sch=FC=DFler).


Since this ticket is closed, I've opened a new one to express my concerns:

https://bugs.ruby-lang.org/issues/15723

----------------------------------------
Feature #4475: default variable name for parameter
https://bugs.ruby-lang.org/issues/4475#change-77263

* Author: jordi (jordi polo)
* Status: Closed
* Priority: Normal
* Assignee: nobu (Nobuyoshi Nakada)
* Target version: =

----------------------------------------
=3Dbegin

There is a very common pattern in Ruby:

 object.method do |variable_name|
  variable_name doing something  =

 end

 Many times in fact the name of the object is so self explanatory that we d=
on't care about the name of the variable of the block. It is common to see =
things like :

 @my_sons.each { |s| s.sell_to_someone }

or

 Account.all.each { |a|  my_account << a.money }


 People tend to choose s or a because we have the class or the object name =
just there to remind you about the context. =



I would like to know if can be a good idea to have a default name for that =
parameter. I think it is Groovy that does something like:

  Account.all.each { my_account << it.money } =


Where it is automagically filled and it doesn't need to be declared.  =


I think it is as readable or more (for newbies who don't know what is ||) a=
nd we save some typing :)


=3Dend




-- =

https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=3Dunsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>