Issue #15582 has been updated by deivid (David Rodr=EDguez).


Hi @hsbt!

I assumed this fix would also fix the incorrect file list for the etc gem's=
 gemspec but I didn't try it and it looks like it didn't actually. On a the=
 default ruby 2.6.2 release, the file list is  `["etc.so", "ext/etc/extconf=
.rb"]`. If I force reinstallation as a default gem, it becomes `[".gitignor=
e".freeze, ".travis.yml".freeze, "Gemfile".freeze, "LICENSE.txt".freeze, "R=
EADME.md".freeze, "Rakefile".freeze, "bin/console".freeze, "bin/setup".free=
ze, "etc.gemspec".freeze, "ext/etc/etc.c".freeze, "ext/etc/extconf.rb".free=
ze, "ext/etc/mkconstants.rb".freeze, "test/etc/test_etc.rb".freeze]`.

This causes some spec failures on bundler's test suite.

Thanks!

----------------------------------------
Bug #15582: default/bundler-1.17.2.gemspec has no file list
https://bugs.ruby-lang.org/issues/15582#change-77104

* Author: mame (Yusuke Endoh)
* Status: Closed
* Priority: Normal
* Assignee: hsbt (Hiroshi SHIBATA)
* Target version: =

* ruby -v: ruby 2.6.1p33 (2019-01-30 revision 66950) [x86_64-linux]
* Backport: 2.4: DONTNEED, 2.5: DONTNEED, 2.6: DONE
----------------------------------------
Ruby 2.6.1's *prefix*/lib/ruby/gems/2.6.0/specifications/default/bundler-1.=
17.2.gemspec seems wrong.

```
  s.files =3D ["bundler.rb".freeze, "exe/bundle".freeze, "exe/bundler".free=
ze]
```

It should have "bundler/setup.rb", "bundler/version.rb", etc.

This causes a trouble depending upon the order of `require` when a differen=
t version of bundler is installed:

```
$ gem list bundler

*** LOCAL GEMS ***

bundler (1.17.3, default: 1.17.2)

$ ruby -e 'require "bundler/version"; require "bundler"; p Bundler::VERSION'
"1.17.2"

$ ruby -e 'require "bundler"; require "bundler/version"; p Bundler::VERSION'
"1.17.3"
```

---Files--------------------------------
15582-bundler-gemspec.patch (5.17 KB)


-- =

https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=3Dunsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>