Sorry to say this, but 1.8.0 seems to have a problem see

  [ruby-core:00685]

pigeon% mkdir /tmp/ruby
pigeon% ./configure --prefix=/tmp/ruby \
 --with-tcl-include=/usr/include/tcl8.4 \
 --enable-ipv6 --with-lookup-order-hack=INET
[...]
pigeon% make
[...]
pigeon% make install
[...]
pigeon% ls -l /tmp/ruby
total 3
drwxrwxrwx    2 ts       ts           1024 Mar  8 14:01 bin/
drwxrwxrwx    3 ts       ts           1024 Mar  8 14:01 lib/
drwxrwxrwx    3 ts       ts           1024 Mar  8 14:01 man/
pigeon%
 
pigeon% /tmp/ruby/bin/ruby -v
ruby 1.8.0 (2003-03-03) [i686-linux]
pigeon% 



Guy Decoux