Issue #15569 has been updated by usa (Usaku NAKAMURA).


FYI, I've never seen GREEN result of the test since last September.
The environment is Windows10 + Visual C++ 14.0(=Visual Studio 2015).

----------------------------------------
Bug #15569: TestResolvDNS#test_no_server always fails on usa's mswin environment
https://bugs.ruby-lang.org/issues/15569#change-76601

* Author: k0kubun (Takashi Kokubun)
* Status: Open
* Priority: Normal
* Assignee: normalperson (Eric Wong)
* Target version: 
* ruby -v: 
* Backport: 2.4: UNKNOWN, 2.5: UNKNOWN, 2.6: UNKNOWN
----------------------------------------
Every week @usa reports a test failure on his mswin environment like this:

```
[  9/135] TestResolvDNS#test_no_server = 5.00 s
  1) Error:
TestResolvDNS#test_no_server:
Timeout::Error: execution expired
    C:/Users/usa/develop/ruby/core/mytree/lib/resolv.rb:672:in `wait_readable'
    C:/Users/usa/develop/ruby/core/mytree/lib/resolv.rb:672:in `request'
    C:/Users/usa/develop/ruby/core/mytree/lib/resolv.rb:526:in `block in fetch_resource'
    C:/Users/usa/develop/ruby/core/mytree/lib/resolv.rb:1120:in `block (3 levels) in resolv'
    C:/Users/usa/develop/ruby/core/mytree/lib/resolv.rb:1118:in `each'
    C:/Users/usa/develop/ruby/core/mytree/lib/resolv.rb:1118:in `block (2 levels) in resolv'
    C:/Users/usa/develop/ruby/core/mytree/lib/resolv.rb:1117:in `each'
    C:/Users/usa/develop/ruby/core/mytree/lib/resolv.rb:1117:in `block in resolv'
    C:/Users/usa/develop/ruby/core/mytree/lib/resolv.rb:1115:in `each'
    C:/Users/usa/develop/ruby/core/mytree/lib/resolv.rb:1115:in `resolv'
    C:/Users/usa/develop/ruby/core/mytree/lib/resolv.rb:517:in `fetch_resource'
    C:/Users/usa/develop/ruby/core/mytree/lib/resolv.rb:507:in `each_resource'
    C:/Users/usa/develop/ruby/core/mytree/lib/resolv.rb:498:in `getresources'
    C:/Users/usa/develop/ruby/core/mytree/test/resolv/test_dns.rb:167:in `block (2 levels) in test_no_server'
    C:/Users/usa/develop/ruby/core/mytree/lib/resolv.rb:300:in `open'
    C:/Users/usa/develop/ruby/core/mytree/test/resolv/test_dns.rb:166:in `block in test_no_server'
    C:/Users/usa/develop/ruby/core/mytree/lib/timeout.rb:108:in `timeout'
    C:/Users/usa/develop/ruby/core/mytree/test/resolv/test_dns.rb:165:in `test_no_server'

Finished tests in 854.592396s, 23.4942 tests/s, 6046.6370 assertions/s.
20078 tests, 5167410 assertions, 0 failures, 1 errors, 328 skips

ruby -v: ruby 2.7.0dev (2019-01-28 trunk 66933) [x64-mswin64_140]
NMAKE : fatal error U1077: '.\ruby.exe' : リターン コード '0x1'
Stop.
```

It started roughly after timer thread was eliminated in Ruby 2.6.
Note that this is not reproducible on mswin RubyCI.

@normalperson Do you have any insight for a possible cause of this?



-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>