Issue #10370 has been updated by shevegen (Robert A. Heiler).


Been a while but Hiroshi put it on the next upcoming developer meeting so I 
guess this may be discussed in a few days.

----------------------------------------
Feature #10370: [PATCH] We don't need to check whether rb_block_call exists
https://bugs.ruby-lang.org/issues/10370#change-76571

* Author: gogotanaka (Kazuki Tanaka)
* Status: Open
* Priority: Normal
* Assignee: 
* Target version: 
----------------------------------------
As far as I know, `rb_iterate` replaced by `rb_block_call` API between Ruby 1.8 and 1.9.

And maintenance of Ruby versions 1.8 ended.

So I think we don't need to check whether rb_block_call exists.

---Files--------------------------------
dont_need_check_whether_rb_block_call_exists.patch (1.45 KB)


-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>