> to_a was too general.  All enumerable objects (and even
> more) have to_a method.  to_ary was too narrow.  Only
> array compatible objects have to_ary.  I wanted
> something in between.

    Without sounding too flippant, why not "to_ar"?  It would be "in
between" to_a and to_ary in all senses.  It would very easy to remember
too.

    - Warren Brown