Issue #15523 has been updated by sawa (Tsuyoshi Sawada).


mame (Yusuke Endoh) wrote:

> I understand that "your problem" is confusion between a keyword "begin" and "Range#begin".  First, I have never been confused by the fact.  Then,

Actually, that was a minor point (I, myself, have not been confused that much. Although I do not like the way it looks to have `begin` and `end` used as methods).

By proposing:

> > * Let Range#begin and Range#end be aliases of Range#first and Range#last, respectively, or

My real intent was that, I don't see any reason for `Range#begin` and `Range#end` to be separate methods from `Range#first` and `Range#last`. If people are indeed going to use `Range#begin` and `Range#end`, then letting them take an optional argument (just like `Range#first` and `Range#last`) would make it simple for everyone.

----------------------------------------
Feature #15523: Let `Range#begin` and `Range#end` be aliases of Range#first and Range#last
https://bugs.ruby-lang.org/issues/15523#change-76327

* Author: sawa (Tsuyoshi Sawada)
* Status: Open
* Priority: Normal
* Assignee: 
* Target version: 
----------------------------------------
My understanding is that `Range#begin` and `Range#end`'s features are just subsets of `Range#first` and `Range#last`, respectively. And since they are slightly confusing with the keywords `begin` and `end`, I propose to either:

* Let `Range#begin` and `Range#end` be aliases of `Range#first` and `Range#last`, respectively, or
* Let `Range#begin` and `Range#end` be obsolete after a migration path of waning against their use and recommending the use of `Range#first` and `Range#last` instead.





-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>