Issue #15528 has been updated by hsbt (Hiroshi SHIBATA).

Assignee set to hsbt (Hiroshi SHIBATA)

----------------------------------------
Bug #15528: Bundler stdlib is not documented
https://bugs.ruby-lang.org/issues/15528#change-76259

* Author: zverok (Victor Shepelev)
* Status: Closed
* Priority: Normal
* Assignee: hsbt (Hiroshi SHIBATA)
* Target version: 
* ruby -v: 
* Backport: 2.4: UNKNOWN, 2.5: UNKNOWN, 2.6: UNKNOWN
----------------------------------------
Since 2.6, Bundler is a part of the standard library. But the logic of standard library docs for "default gems" (only gem's `lib` is copied to Ruby source tree, and libraries main class/module is rendered as a docs entry point) lead to unusable documentation for Bundler: https://docs.ruby-lang.org/en/2.6.0/Bundler.html

I am not sure how the situation should be handled, I can imagine at least 3 possible approaches:
1. Work with Bundler team to have "basic usage" docs in `lib/bundler.rb`
2. More sophisticated code copying (like copying parts of bundler's docs into `lib/bundler.rb` **only in Ruby source tree**)
3. Rethink stdlib docs rendering to include default gems READMEs (will also require READMEs to be copied)

(1) is probably the simplest, though I am not sure Bundler team is ready to participate.



-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>