Issue #15523 has been updated by shevegen (Robert A. Heiler).


I have no particular pro or con opinion towards this proposal per se; however within
the two suggestions made, I think having these as aliases would be better than
obsolete them. People could then decide to use either variant if they would like
to whereas with the second suggestion they may be first to forego the use of
begin/end as method names. Note that I understand the intent behind the 
deprecation thought, but I think it would still be better for ruby folks to decide
on their own what they would prefer. Not everyone is necessarily confused, although
I understand that it may be confusing for some.

(But again, I do not have any particular strong pro or con opinion as such. I actually
think that I may not have used #first or #last on Range so far in my own code
altogether; neither #begin or #end).

----------------------------------------
Feature #15523: `Range#begin` and `Range#end`
https://bugs.ruby-lang.org/issues/15523#change-76245

* Author: sawa (Tsuyoshi Sawada)
* Status: Open
* Priority: Normal
* Assignee: 
* Target version: 
----------------------------------------
My understanding is that `Range#begin` and `Range#end`'s features are just subsets of `Range#first` and `Range#last`, respectively. And since they are slightly confusing with the keywords `begin` and `end`, I propose to either:

* Let `Range#begin` and `Range#end` be aliases of `Range#first` and `Range#last`, respectively, or
* Let `Range#begin` and `Range#end` be obsolete after a migration path of waning against their use and recommending the use of `Range#first` and `Range#last` instead.





-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>