Issue #15321 has been updated by duerst (Martin Drst).


I have confirmed that Ruby can be updated to Unicode 12.0.0 and all tests (`make check`) are passed correctly with the Unicode 12.0.0 beta data (http://unicode.org/versions/beta-12.0.0.html). This means that there may be only minor (or no) problems to update Ruby to Unicode 12.0.0 after it's official publication (currently planned to happen on March 5).

----------------------------------------
Feature #15321: Update Unicode data to Unicode Version 12.0.0
https://bugs.ruby-lang.org/issues/15321#change-76088

* Author: duerst (Martin Drst)
* Status: Open
* Priority: Normal
* Assignee: 
* Target version: 
----------------------------------------
Unicode Version 12.0.0 will be published in 2019, earlier than Unicode 11.0.0 in 2018. This is an issue to manage updating Ruby to Unicode 12.0.0. Details to follow.

The target version may be Ruby 2.6.1 or 2.7.



-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>