Issue #15469 has been updated by watson1978 (Shizuo Fujita).


I need that CSV::VERSION indicates 2.4.8 as well as Workaround.

----------------------------------------
Bug #15469: Ruby2.6 included `bundler` does not handle specified `csv` gem.
https://bugs.ruby-lang.org/issues/15469#change-75935

* Author: watson1978 (Shizuo Fujita)
* Status: Assigned
* Priority: Normal
* Assignee: hsbt (Hiroshi SHIBATA)
* Target version: 
* ruby -v: 
* Backport: 2.4: UNKNOWN, 2.5: UNKNOWN, 2.6: UNKNOWN
----------------------------------------
I want to use `csv` library which is same version of Ruby 2.5.
Because Ruby 2.6's csv library has some breaking changes and they break our product.

However, Ruby 2.6's `bundler` does not handle `csv` which I specified the version.

## Test code

* Gemfile

```
source "https://rubygems.org"

gem 'roo'
gem 'csv', '1.0.0'
```

* test.rb

```
require "bundler/setup"
require "csv"

p CSV::VERSION
```

## Result

```
$ bundle exec ruby -v test.rb
ruby 2.6.0p0 (2018-12-25 revision 66547) [x86_64-darwin18]
"3.0.2"
```

`CSV::VERSION` shows `3.0.2` and  it indicates that Ruby 2.6 included `csv` library was used.

## Workaround
If I install the `bundler` gem through `gem install bundler`, it works well.

```
$ gem install bundler
Fetching bundler-1.17.3.gem
Successfully installed bundler-1.17.3
1 gem installed

$ bundle exec ruby -v test.rb
ruby 2.6.0p0 (2018-12-25 revision 66547) [x86_64-darwin18]
"2.4.8"
```



-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>