Issue #15436 has been updated by shevegen (Robert A. Heiler).


ffi could be found here as source package: ftp://sourceware.org/pub/libffi/libffi-3.2.1.tar.gz

That one also provides ffi.h; I assume opensuse has this also packaged up somewhere, possibly
a -dev/-devel package or something.

I don't know anything about the first error; thankfully Jeremy already commented above.


----------------------------------------
Bug #15436: Tests failing in `make check`
https://bugs.ruby-lang.org/issues/15436#change-75783

* Author: ana06 (Ana Maria Martinez Gomez)
* Status: Open
* Priority: Normal
* Assignee: 
* Target version: 
* ruby -v: trunk branch in Github
* Backport: 2.4: UNKNOWN, 2.5: UNKNOWN
----------------------------------------
The following tests fail when running `check make` (after `make`) in my openSUSE Tumbleweed using current Ruby trunk version:


```
[ 1080/19451] OpenSSL::TestEC#test_ec_point_mul = 0.00 s                                            
  1) Error:
OpenSSL::TestEC#test_ec_point_mul:
OpenSSL::PKey::EC::Point::Error: called a function you should not call
    /home/ana/github/ruby/test/openssl/test_pkey_ec.rb:312:in `mul'
    /home/ana/github/ruby/test/openssl/test_pkey_ec.rb:312:in `test_ec_point_mul'

[ 6846/19451] TestExtLibs#test_existence_of_fiddle = 0.07 s                                                                                    
  2) Failure:
TestExtLibs#test_existence_of_fiddle [/home/ana/github/ruby/test/test_extlibs.rb:20]:
extension library `fiddle' is not found
"pkg-config --exists libffi"
package configuration for libffi is not found
have_header: checking for ffi.h... -------------------- no
```

The second seems to be a problem package and not code related - a problem which I don't manage to solve.... :(
But I am not that sure with the first one.





-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>