Issue #15219 has been updated by naruse (Yui NARUSE).

Tracker changed from Feature to Bug
Status changed from Open to Closed
Backport set to 2.4: DONTNEED, 2.5: UNKNOWN

Close to be on tracking on backport process.

----------------------------------------
Bug #15219: Backport: Ruby 2.5.X to support OpenSSL 1.1.1 and TLS 1.3
https://bugs.ruby-lang.org/issues/15219#change-75735

* Author: jaruga (Jun Aruga)
* Status: Closed
* Priority: Normal
* Assignee: 
* Target version: 
* ruby -v: 
* Backport: 2.4: DONTNEED, 2.5: UNKNOWN
----------------------------------------
I would be happy that the coming Ruby 2.5.2 would support OpenSSL 1.1.1 and TLS 1.3 [1].

To do that, it seems at least below patch has to be backported to Ruby 2.5.

net/http, net/ftp: fix session resumption with TLS 1.3
https://github.com/ruby/ruby/commit/1dfc377

And new ruby/openssl 2.2.2 has to be bundled in the Ruby 2.5.2.

Possible?
Thank you.

[1] OpenSSL 1.1.1 release note: https://www.openssl.org/blog/blog/2018/09/11/release111/




-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>