> https://bugs.ruby-lang.org/issues/14813#change-75529
> 
> I have no strong idea. If it will help for systemtap user. I don't care.
> (I feel changinge "gc_enter" to "GC_ENTER" is a bit difficult to read, but I understand why...).

I think the caps change is a minor issue.  It's more important to
use ALL_CAPS to help identify macros (because of side-effects).

Anyways, updated patch here:
https://80x24.org/spew/20181216120630.17237-2-e / 80x24.org/raw
(tested on FreeBSD 11.2 and Debian 9.6)


Still waiting on @tenderlovemaking for [Bug #15399] on
duparray/duphash hook tracing comments

Sidenote:

Since I always build my own kernels and usually run the latest
kernel, systemtap remains a pain because it relies heavily on
kernel internals.  Given that, systemtap should probably be like
perf(1) and be maintained/distributed with the kernel (and the
default prefix should be $HOME :P)

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>