On Oct 9, 2006, at 10:19 AM, dblack / wobblini.net wrote:

> Hi --
>
> On Mon, 9 Oct 2006, Yukihiro Matsumoto wrote:
>
>> Hi,
>>
>> In message "Re: [ruby-cvs:18323] ruby: * eval.c (splat_value): use  
>> "to_splat" instead of "to_ary" to"
>>    on Mon, 9 Oct 2006 23:06:57 +0900, dblack / wobblini.net writes:
>>
>> |> Um.  For "to_" + verb, we already have "to_open".  I am open  
>> for the
>> |> better name proposal, as always.
>> |
>> |I can't find to_open (is it in an extension?) but I don't think
>> |to_verb is good.  At least open is also an adjective... but even if
>> |there's one to_verb, I really strongly recommend against having  
>> more.
>> |It just sounds wrong, and definitely has the "added to the language
>> |later" feel.
>>
>> It's only in 1.9.
>>
>> |I gather you don't like "unarray" :-)  I wish * were available.
>> |"star" or "starred", maybe?  Does it have to be to_something?
>>
>> You mean "to_star"?  I like the "to_" name for internal conversion
>> methods.
>
> I actually meant just "starred", without the to_.  I'm not sure the
> to_ makes sense.  With the conversions (to_something), the "something"
> is always (?) a recognizable, core class: to_i, to_s, to_f, etc.

to_params

Just a thought.

James Edward Gray II