On Mon, 9 Oct 2006, Yukihiro Matsumoto wrote:

> Hi,
> 
> In message "Re: [ruby-cvs:18323] ruby: * eval.c (splat_value): use "to_splat" instead of "to_ary" to"
>     on Mon, 9 Oct 2006 23:06:57 +0900, dblack / wobblini.net writes:
> 
> |> Um.  For "to_" + verb, we already have "to_open".  I am open for the
> |> better name proposal, as always.
> |
> |I can't find to_open (is it in an extension?) but I don't think
> |to_verb is good.  At least open is also an adjective... but even if
> |there's one to_verb, I really strongly recommend against having more.
> |It just sounds wrong, and definitely has the "added to the language
> |later" feel.
> 
> It's only in 1.9.
> 
> |I gather you don't like "unarray" :-)  I wish * were available.
> |"star" or "starred", maybe?  Does it have to be to_something?
> 
> You mean "to_star"?  I like the "to_" name for internal conversion
> methods.

I'm probably getting confused here, but isn't this operator doing
something like: peel the outer [] off the array, leaving any nested
arrays intact?  If that is near the mark, then 

http://moonbase.rydia.net/mental/writings/programming/monads-in-ruby/02array

talks about mjoin, a Monadic join.  Now, I still don't fully understand
monads, probably because I don't use them enough, but maybe something
there may provide sufficient stimulation to produce a really good answer. 

You are not only applying this to_<something> to arrays, so this may 
be of no *direct* help, but it might possibly help indirectly.
> 
> 							matz.
> 

        Hugh