Issue #15171 has been updated by MSP-Greg (Greg L).

File av_openssl_1.1.1.patch added
Subject changed from OpenSSL 1.1.1 soon available from MSYS2 to [patch] Use OpenSSL 1.1.1 for Appveyor MinGW build

Attached is patch file that updates Appveyor.yml to:

1. Update to the current MSYS2/MinGW OpenSSL package for the mingw build (as of 2018-Oct, 1.1.1)

2. Outputs OpenSSL version info at end of each build

The patch passed on my fork, see
https://ci.appveyor.com/project/MSP-Greg/ruby/builds/19619466

Notes:
3. The current code for the mingw build does not update all MSYS2 packages.  Due to some file casing issues, the old OpenSSL package must be removed prior to installing the new one.

4. At present, Appveyor has the OpenSSL-Win64 vc software installed.  The dll's for it are incorrectly placed in the System32 directory.  They need to be renamed before running (testing) the mingw build.  I've had the same issue with ruby-loco for a few months.

5. The OpenSSL-Win64 package version is 1.0.2p.  OpenSSL-Win64 is available for 1.1.0i or 1.1.1, I believe it is a vc140 build.  It could be downloaded and used for the mswin builds.

6. I do have vc120 and vc140 builds of OpenSSL 1.1.1 on BinTray.

----------------------------------------
Feature #15171: [patch] Use OpenSSL 1.1.1 for Appveyor MinGW build
https://bugs.ruby-lang.org/issues/15171#change-74501

* Author: MSP-Greg (Greg L)
* Status: Open
* Priority: Normal
* Assignee: 
* Target version: 
----------------------------------------
@nobu

Thanks for your work with the Appveyor testing.  It took three revisions, but MSYS2 has jumped from OpenSSL 1.0.2 to 1.1.1.  The package release 1.1.1-4 should build fine on Appveyor MinGW.  I don't think it has hit the MSYS2 repository yet, but certainly in the next 24 hours.

If you've got MSYS2 installed, `pacman -Ss mingw-w64-x86_64-openssl` should show availability.  But you knew that.

Hence, line 122 of the current Appveyor.yml file would need mingw-w64-x86_64-openssl added to it.  At present, Appveyor has got 1.0.2p.

Lastly, given any thought to moving the VC builds to Azure?  I may see if I can make both VC12 and VC14 OpenSSL packages.  Seems inappropriate to load different runtimes with (I think) VC12.

Greg

---Files--------------------------------
av_openssl_1.1.1.patch (2.09 KB)


-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>