Issue #15232 has been reported by wanabe (_ wanabe).

----------------------------------------
Bug #15232: Is https://cache.ruby-lang.org/pub/ruby/2.5/ruby-2.5.2.tar.bz2 corrupted?
https://bugs.ruby-lang.org/issues/15232

* Author: wanabe (_ wanabe)
* Status: Open
* Priority: Normal
* Assignee: 
* Target version: 
* ruby -v: 
* Backport: 2.3: UNKNOWN, 2.4: UNKNOWN, 2.5: UNKNOWN
----------------------------------------
Hello,

I'm glad for new ruby release. Thank you so much.

I tried to build ruby-2.5.2 in docker environment, but I couldn't and got a such error.

```
[root@9838dd79fcdd tmp]# rbenv install 2.5.2
Downloading ruby-2.5.2.tar.bz2...
-> https://cache.ruby-lang.org/pub/ruby/2.5/ruby-2.5.2.tar.bz2
Installing ruby-2.5.2...

BUILD FAILED (CentOS release 6.10 (Final) using ruby-build 20180822-14-gcbbd3c2)

Inspect or clean up the working tree at /tmp/ruby-build.20181018003202.361
Results logged to /tmp/ruby-build.20181018003202.361.log

Last 10 log lines:
/tmp/ruby-build.20181018003202.361 /tmp
/tmp/ruby-build.20181018003202.361/ruby-2.5.2 /tmp/ruby-build.20181018003202.361 /tmp
checking for ruby... false
configure: error: cannot run /bin/sh tool/config.sub
```

I guess `tool/config.sub` and `tool/config.guess` are corrupted unexpectedly.

```
[root@9838dd79fcdd tmp]# ls -la /tmp/ruby-build.20181018003202.361/ruby-2.5.2/tool/config.*
lrwxrwxrwx 1 1044 1044 33 Oct 18 00:32 /tmp/ruby-build.20181018003202.361/ruby-2.5.2/tool/config.guess -> ../.downloaded-cache/config.guess
lrwxrwxrwx 1 1044 1044 31 Oct 18 00:32 /tmp/ruby-build.20181018003202.361/ruby-2.5.2/tool/config.sub -> ../.downloaded-cache/config.sub
```

On another environment that has BASERUBY, I confirmed to run `configure`.

```
/tmp/ruby-2.5.2 $ ./configure
checking for ruby... /home/wanabe/.rbenv/shims/ruby
downloading config.guess ... done
downloading config.sub ... done
í╩snipí╦
```



-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>