Issue #15219 has been updated by shevegen (Robert A. Heiler).


This would be nice indeed. I have a small gem that collects information about the
host-system (on the target computer platform; usually linux) available, and notifies
when there are more recent versions. I am a bit wary of upgrading openssl from
openssl-1.1.0i to openssl-1.1.1 mostly because I am never absolutely sure how well
a more recent openssl may work with ruby. And the primary reason for me to use
openssl (and have ruby support it, too) is so that I can push new gem releases
of my code.

So naturally, I think it would be nice if more recent openssl versions could be
supported on 2.5.x too.

Having said that, I think after x-mas, I will be using ruby 2.6.x so it would not
be of a massive benefit to me personally.

On a side note, if it were possible, it may be helpful to notify on the ruby-doc
website which versions of a particular software is supported.

Take:

https://ruby-doc.org/stdlib/libdoc/openssl/rdoc/OpenSSL.html

This page could list which version is compatible - or at the least has
been tested. I don't know of a good way to have this automatically for
all versions, but I think it may be useful for quite a few people. (Openssl,
zlib and Readline are usually what I need to have in the local ruby version,
since it is very convenient or necessary for other things.)

I think naruse is in charge of handling both 2.6.x and 2.5.x release so perhaps
he should be asked.

----------------------------------------
Feature #15219: Ruby 2.5.X supporting OpenSSL 1.1.1 and TLS 1.3
https://bugs.ruby-lang.org/issues/15219#change-74371

* Author: jaruga (Jun Aruga)
* Status: Open
* Priority: Normal
* Assignee: 
* Target version: 
----------------------------------------
I would be happy that the coming Ruby 2.5.2 would support OpenSSL 1.1.1 and TLS 1.3 [1].

To do that, it seems at least below patch has to be backported to Ruby 2.5.

net/http, net/ftp: fix session resumption with TLS 1.3
https://github.com/ruby/ruby/commit/1dfc377

And new ruby/openssl 2.2.2 has to be bundled in the Ruby 2.5.2.

Possible?
Thank you.

[1] OpenSSL 1.1.1 release note: https://www.openssl.org/blog/blog/2018/09/11/release111/




-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>