Issue #15069 has been updated by shyouhei (Shyouhei Urabe).

Status changed from Open to Closed

(Changing status to closed; it triggers backporting process.  This doesn't mean rejection.)

----------------------------------------
Bug #15069: Backport "suppress warning: 'const' attribute on function returning 'void' "
https://bugs.ruby-lang.org/issues/15069#change-73883

* Author: larskanis (Lars Kanis)
* Status: Closed
* Priority: Normal
* Assignee: 
* Target version: 
* ruby -v: ruby 2.4.4p296 (2018-03-28 revision 63013) [x64-mingw32]
* Backport: 2.3: UNKNOWN, 2.4: UNKNOWN, 2.5: UNKNOWN
----------------------------------------
The files `include/ruby/intern.h` and `include/ruby/ruby.h` are used for extension builds, and when a recent gcc is called with -Wall, the build fails. This can cause failures with mkmf for instance in pkg_config() lookup.

The resolving commit to ruby-2.5 was: https://github.com/ruby/ruby/commit/027b576b31cd12bad575b3a39476726273f58c41
Can this commit please be backported to older ruby versions?

[This patch](https://github.com/oneclick/rubyinstaller2-packages/commit/7dad058a504be94ea03fde982965194d3bfe1ea7) is also used for RubyInstaller-2.4.



-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>