Issue #14754 has been updated by nagachika (Tomoyuki Chikanaga).

Backport changed from 2.3: DONTNEED, 2.4: DONE, 2.5: REQUIRED to 2.3: DONTNEED, 2.4: DONE, 2.5: DONE

ruby_2_5 r64428 merged revision(s) 63406.

----------------------------------------
Bug #14754: Backport openssl v2.1.1 / v2.0.8
https://bugs.ruby-lang.org/issues/14754#change-73582

* Author: rhenium (Kazuki Yamaguchi)
* Status: Closed
* Priority: Normal
* Assignee: 
* Target version: 
* ruby -v: 
* Backport: 2.3: DONTNEED, 2.4: DONE, 2.5: DONE
----------------------------------------
Ruby/OpenSSL 2.1.1 and 2.0.8 contain some bug fixes, including compatibility with LibreSSL 2.7.x.

  https://github.com/ruby/openssl/compare/v2.1.0...v2.1.1

trunk is updated to v2.1.1 by r63406.

Ruby 2.5 maintainer: Please backport r63406.
Ruby 2.4 maintainer: The branch is currently at v2.0.7 and the diff does not apply. Please apply the attached patch. It is basically identical to r63406 + r61277 with the difference in version number.

---Files--------------------------------
0001-openssl-import-v2.0.8.patch (12.1 KB)


-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>