Issue #14350 has been updated by nagachika (Tomoyuki Chikanaga).

Backport changed from 2.3: DONTNEED, 2.4: DONTNEED, 2.5: REQUIRED to 2.3: DONTNEED, 2.4: DONTNEED, 2.5: DONE

ruby_2_5 r64195 merged revision(s) 61766.

----------------------------------------
Bug #14350: Strange behavior for Array.min in ruby 2.5.0
https://bugs.ruby-lang.org/issues/14350#change-73316

* Author: artofhuman (Semyon Pupkov)
* Status: Closed
* Priority: Normal
* Assignee: 
* Target version: 
* ruby -v: 2.5.0
* Backport: 2.3: DONTNEED, 2.4: DONTNEED, 2.5: DONE
----------------------------------------
2.4.2

~~~ ruby
[[1, 0.0].max, 1.0].min

=> 1
~~~

2.5.0

~~~ ruby
[[1, 0.0].max, 1.0].min

=> 1.0

[[1, 0.0].max, 1.0]

=> [1, 1.0]

[1, 1.0].min

=> 1
~~~

I think it`s regression for ruby 2.5.0



-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>