Issue #11370 has been updated by jeremyevans0 (Jeremy Evans).

Status changed from Open to Closed

Closing this as it doesn't seem to be an issue in recent Ruby/OpenBSD versions.

----------------------------------------
Bug #11370: Use slightly less strict test for heap_eden_pages
https://bugs.ruby-lang.org/issues/11370#change-73297

* Author: jeremyevans0 (Jeremy Evans)
* Status: Closed
* Priority: Normal
* Assignee: 
* Target version: 
* ruby -v: ruby 2.3.0dev (2015-07-16 openbsd 51261) [x86_64-openbsd]
* Backport: 2.0.0: UNKNOWN, 2.1: UNKNOWN, 2.2: UNKNOWN
----------------------------------------
On OpenBSD a delta of 1 leads to occassional test failures:

  1) Failure:
TestGc#test_expand_heap [/home/jeremy/code/ruby/test/ruby/test_gc.rb:292]:
invalid heap expanding (base_length: 286, GC.stat[:heap_eden_pages]: 288).
Expected |286 - 288| (2) to be <= 1.

---Files--------------------------------
0008-Use-slightly-less-strict-test-for-heap_eden_pages.patch (1.01 KB)


-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>