Issue #14943 has been reported by repeatedly (Masahiro Nakagawa).

----------------------------------------
Bug #14943: ruby 2.4 doesn't work with jemalloc 5.1.0 properly.
https://bugs.ruby-lang.org/issues/14943

* Author: repeatedly (Masahiro Nakagawa)
* Status: Open
* Priority: Normal
* Assignee: 
* Target version: 
* ruby -v: 2.4.4
* Backport: 2.3: UNKNOWN, 2.4: UNKNOWN, 2.5: UNKNOWN
----------------------------------------
With jemalloc 5.1.0, ruby 2.4.4 failed to initalize timer thread and it causes broken runtime, e.g. signals are ignored.

- ruby 2.4.4

~~~
$ LD_PRELOAD=~/jemalloc_lib/5.1.0/lib/libjemalloc.so.2 ruby print_version.rb 
<main>: warning: pthread_create failed for timer: Invalid argument, scheduling broken
2.4.4
~~~

- ruby 2.5.1

~~~
$ LD_PRELOAD=~/jemalloc_lib/5.1.0/lib/libjemalloc.so.2 ruby print_version.rb 
2.5.1
~~~

This problem has been reported in jemalloc issue. See https://github.com/jemalloc/jemalloc/issues/1006



-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>