Issue #14849 has been updated by shyouhei (Shyouhei Urabe).

Status changed from Open to Feedback

2.4.0 is too old.  Try 2.5.1, or at least, 2.4.4.

----------------------------------------
Bug #14849: rbenv install 2.4.0 on AWS EC2 on AMI linux box
https://bugs.ruby-lang.org/issues/14849#change-72508

* Author: reepz (Andrzej Wojtowicz)
* Status: Feedback
* Priority: Normal
* Assignee: 
* Target version: 
* ruby -v: 2.4.0
* Backport: 2.3: UNKNOWN, 2.4: UNKNOWN, 2.5: UNKNOWN
----------------------------------------
unable to install 2.4.0 ruby while with rbenv:

AMI ID: amzn-ami-hvm-2018.03.0.20180508-x86_64-gp2 (ami-9a91b371)

================================================
[ec2-user@ip-*********** ~]$ rbenv install 2.4.0  
Installing ruby-2.4.0...

BUILD FAILED (Amazon Linux AMI 2018.03 using ruby-build 20180601)

Inspect or clean up the working tree at /tmp/ruby-build.20180615183213.12665
Results logged to /tmp/ruby-build.20180615183213.12665.log

Last 10 log lines:
7ffc7937f000-7ffc79381000 r-xp 00000000 00:00 0                          [vdso]
ffffffffff600000-ffffffffff601000 r-xp 00000000 00:00 0                  [vsyscall]


[NOTE]
You may have encountered a bug in the Ruby interpreter or extension libraries.
Bug reports are welcome.
For details: http://www.ruby-lang.org/bugreport.html

make: *** [rdoc] Aborted




-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>