Issue #14747 has been updated by duerst (Martin Drst).


janfri (Jan Friedrich) wrote:

> Hey this is my patch. ;-) I did the same and it worked for me. But for the actual trunk it seems not longer to be necessary?

I removed my/your 'patch' (see https://bugs.ruby-lang.org/issues/14747#note-6), and the compilation continued to work. So I'll close this issue.

So this seems to be a transient issue, but it doesn't go away by removing everything and checking out all of the source from scratch. I don't know why, but anyway, we have a solution.

----------------------------------------
Bug #14747: uninitialized constant Gem::PathSupport
https://bugs.ruby-lang.org/issues/14747#change-72212

* Author: duerst (Martin Drst)
* Status: Assigned
* Priority: Normal
* Assignee: hsbt (Hiroshi SHIBATA)
* Target version: 
* ruby -v: ruby 2.3.6p384 (2017-12-14 revision 9808) [x86_64-cygwin] last_commit=ruby 2.3.3
* Backport: 2.3: UNKNOWN, 2.4: UNKNOWN, 2.5: UNKNOWN
----------------------------------------
I'm getting the following error repeatedly:

```
/cygdrive/c/Data/ruby/lib/rubygems.rb:393:in `paths': uninitialized constant Gem::PathSupport (N   ameError)
make: *** [uncommon.mk:353: do-install-nodoc] Error 1
```

I have set --with-baseruby=/usr/bin/ruby, which is an old version of ruby, and started from ./configure, but that doesn't help.

The command I use to compile is
```
make up unicode-up install-nodoc runnable
```

The source is at the newest revision, r63393.



-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>