Issue #14733 has been updated by gotoken (Kentaro Goto).

Status changed from Open to Rejected

I tried to reproduce the issue because I have Vagrant 2.0.4 on Windows 10 1709 by chance. I cannot reproduce though. `vagrant ssh` succeed. Your screenshot shows that ruby runs in the debian box but vanilla wheezy box does not includea ruby. See log the below. {{collapse
```
PS C:\vagrant\debianwheezy64> vagrant init debian/wheezy64
A `Vagrantfile` has been placed in this directory. You are now
ready to `vagrant up` your first virtual environment! Please read
the comments in the Vagrantfile as well as documentation on
`vagrantup.com` for more information on using Vagrant.
PS C:\vagrant\debianwheezy64> vagrant up
Bringing machine 'default' up with 'virtualbox' provider...
==> default: Box 'debian/wheezy64' could not be found. Attempting to find and install...
    default: Box Provider: virtualbox
    default: Box Version: >= 0
==> default: Loading metadata for box 'debian/wheezy64'
    default: URL: https://vagrantcloud.com/debian/wheezy64
==> default: Adding box 'debian/wheezy64' (v7.11.2) for provider: virtualbox
    default: Downloading: https://vagrantcloud.com/debian/boxes/wheezy64/versions/7.11.2/providers/virtualbox.box
    default:
==> default: Successfully added box 'debian/wheezy64' (v7.11.2) for 'virtualbox'!
==> default: Importing base box 'debian/wheezy64'...
==> default: Matching MAC address for NAT networking...
==> default: Checking if box 'debian/wheezy64' is up to date...
==> default: Setting the name of the VM: debianwheezy64_default_1525510691501_57527
==> default: Clearing any previously set network interfaces...
==> default: Preparing network interfaces based on configuration...
    default: Adapter 1: nat
==> default: Forwarding ports...
    default: 22 (guest) => 2222 (host) (adapter 1)
==> default: Booting VM...
==> default: Waiting for machine to boot. This may take a few minutes...
    default: SSH address: 127.0.0.1:2222
    default: SSH username: vagrant
    default: SSH auth method: private key
    default:
    default: Vagrant insecure key detected. Vagrant will automatically replace
    default: this with a newly generated keypair for better security.
    default:
    default: Inserting generated public key within guest...
    default: Removing insecure key from the guest if it's present...
    default: Key inserted! Disconnecting and reconnecting using new SSH key...
==> default: Machine booted and ready!
==> default: Checking for guest additions in VM...
    default: No guest additions were detected on the base box for this VM! Guest
    default: additions are required for forwarded ports, shared folders, host only
    default: networking, and more. If SSH fails on this machine, please install
    default: the guest additions and repackage the box to continue.
    default:
    default: This is not an error message; everything may continue to work properly,
    default: in which case you may ignore this message.
==> default: Installing rsync to the VM...
==> default: Rsyncing folder: /cygdrive/c/vagrant/debianwheezy64/ => /vagrant
PS C:\vagrant\debianwheezy64> vagrant ssh
Linux wheezy 3.2.0-4-amd64 #1 SMP Debian 3.2.81-1 x86_64

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
vagrant@wheezy:~$ dpkg -l | grep ruby | wc -l
0
vagrant@wheezy:~$ ruby -v
-bash: ruby: command not found
vagrant@wheezy:~$ logout
Connection to 127.0.0.1 closed.
PS C:\vagrant\debianwheezy64> vagrant --version
Vagrant 2.0.4
```
}}

Any way, this issue is not a problem of ruby interpreters nor ruby language and I set status reject. 

You might get helps at box the issue tracker of the box you used or at ruby-talk mailing list.

----------------------------------------
Bug #14733: Error on reading log4r
https://bugs.ruby-lang.org/issues/14733#change-71861

* Author: cardillos (cherry ard)
* Status: Rejected
* Priority: Normal
* Assignee: 
* Target version: 
* ruby -v: ruby 2.3.6p384 (2017-12-14 revision 9808)
* Backport: 2.3: UNKNOWN, 2.4: UNKNOWN, 2.5: UNKNOWN
----------------------------------------
Hello all,
I used Vagrant on Windows 10 which is using Ruby.
Here is the error on the log 

!verror.png!

Any idea anyone?

---Files--------------------------------
verror.png (8.48 KB)


-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>