Issue #13655 has been updated by usa (Usaku NAKAMURA).

Backport changed from 2.2: REQUIRED, 2.3: REQUIRED, 2.4: DONE to 2.2: REQUIRED, 2.3: DONE, 2.4: DONE

ruby_2_3 r62937 merged revision(s) 61278,61281.

----------------------------------------
Bug #13655: external encoding named "-" (doc issue orí─?)
https://bugs.ruby-lang.org/issues/13655#change-71265

* Author: shyouhei (Shyouhei Urabe)
* Status: Closed
* Priority: Normal
* Assignee: stomar (Marcus Stollsteimer)
* Target version: 2.5
* ruby -v: ruby 2.5.0dev (2017-06-09 trunk 59055) [x86_64-darwin15]
* Backport: 2.2: REQUIRED, 2.3: DONE, 2.4: DONE
----------------------------------------
IO.new's document explicitly states that it accepts "-" as external encoding:

https://github.com/ruby/ruby/blob/d0015e4ac6b812ea1681b1f5fa86fbab52a58960/io.c#L7790

which is not true.

```
% ruby -ve 'IO.new(0, external_encoding: "-")'
ruby 2.5.0dev (2017-06-09 trunk 59055) [x86_64-darwin15]
Traceback (most recent call last):
        2: from -e:1:in `<main>'
        1: from -e:1:in `new'
-e:1:in `initialize': unknown encoding name - - (ArgumentError)
```



-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>