Dne 19.3.2018 v 20:00 aycabta / gmail.com napsal(a):
>
> ## Use-case
>
> I'm developing Readline compatible library by pure Ruby implementation for Ruby core.
> https://github.com/aycabta/reline
>
> I'm discussing it with @hsbt, and I think that the pure Ruby version should be used only when the native extension version doesn't exist.
> ref. https://bugs.ruby-lang.org/issues/11084
> The Readline library is very important for that IRB *always* provides Readline's features.

Just out of curiosity, why are you reimplementing readline in pure Ruby
if there exists rb-readline [1], used by Ruby Installer.

Vt


[1] https://github.com/ConnorAtherton/rb-readline

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>