Issue #14465 has been reported by mcr (Michael Richardson).

----------------------------------------
Feature #14465: rename/alias and then obsolete UDPSocket::send
https://bugs.ruby-lang.org/issues/14465

* Author: mcr (Michael Richardson)
* Status: Open
* Priority: Normal
* Assignee: 
* Target version: 
----------------------------------------

The method name "send" on UDPSocket  <https://ruby-doc.org/stdlib-2.5.0/libdoc/socket/rdoc/UDPSocket.html#method-i-send> is confusing and inconsistent.
The underlying libc method is called sendto(2) (or sendmsg()).  The method "send" is confused with <https://ruby-doc.org/core-2.5.0/Object.html#method-i-send>
I suggest:
   1. we rename it to sendto, leaving an alias.
   2. mark UDPSocket::send as obsoleted
   3. remove it in a future version

Some things like Celluloid::IO and the like will need encouragement to duck type the new interface sooner.




-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>