Issue #10643 has been updated by MSP-Greg (Greg L).


@nagachika

First of all, I'd like to apologize for the above, as it is incorrect.  I revisited this (ruby-loco 'broke' due to the renaming of configure.in to configure.ac), and the commit that fixed the failure was 59040 aac0b43 (by @nobu).  I tried to apply it to ruby_2_4, but could not do so, as there was an issue in dir.c.  Also, I believe 59061 ff5e3b9 moves some of the code.

Not being fluent in c, I'd probably stumble around for quite a while trying to determine what additional previous commits would need to be in place for 59040 to work with ruby_2_4.

Question - Ruby 2.4 - AFAIK, no one has shown test-all results for '2.4.x' or the stable branch.  Would that be helpful in terms of determining what to backport?  The last time I ran 2.4 (2_4.2 p173 2017-08-05), there were six failures.

Thanks, Greg

----------------------------------------
Bug #10643: 2.2: TestRubyOptions#test_command_line_progname_nonascii test failure (MinGW)
https://bugs.ruby-lang.org/issues/10643#change-69570

* Author: luislavena (Luis Lavena)
* Status: Closed
* Priority: Normal
* Assignee: nobu (Nobuyoshi Nakada)
* Target version: 
* ruby -v: ruby 2.2.0dev (2014-12-24) [i386-mingw32]
* Backport: 2.4: REQUIRED, 2.5: DONTNEED
----------------------------------------
Hello,

Running tests against ruby_2_2 branch, the following failures were detected (mingw-w64 4.7.2 32bits, GCC 4.7.2, Windows 7 x64):

~~~
TestRubyOptions#test_command_line_progname_nonascii [C:/Users/Luis/Code/ruby/ruby/test/ruby/test_rubyoptions.rb:719]:
[ruby-dev:48752] [Bug #10555].
<["?.rb"]> expected but was
<[]>.
---
<[]> expected but was
<["C:\\Users\\Luis\\Code\\oneclick\\rubyinstaller\\sandbox\\ruby21_build\\ruby.exe: Invalid argument -- ?.rb (LoadError)"]>.
~~~




-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>