Issue #10643 has been updated by nagachika (Tomoyuki Chikanaga).

Status changed from Assigned to Closed
Backport changed from 2.0.0: UNKNOWN, 2.1: UNKNOWN, 2.2: REQUIRED to 2.4: REQUIRED, 2.5: DONTNEED

Thank you MSP-Greg,

So the issue was fixed on trunk during 2.5.0 development.
I have to find which revisions fixed this failure.

I roughly seek related revisions and found r58767.
But I don't have environment to confirm the result.
I have confirmed the patch from r58767 can be cleanly applied into ruby_2_4.
Could you check if the following patch fixes the test failure?

https://svn.ruby-lang.org/cgi-bin/viewvc.cgi/trunk/ruby.c?r1=58767&r2=58766&pathrev=58767&view=patch

Best Regard,

----------------------------------------
Bug #10643: 2.2: TestRubyOptions#test_command_line_progname_nonascii test failure (MinGW)
https://bugs.ruby-lang.org/issues/10643#change-69512

* Author: luislavena (Luis Lavena)
* Status: Closed
* Priority: Normal
* Assignee: nobu (Nobuyoshi Nakada)
* Target version: 
* ruby -v: ruby 2.2.0dev (2014-12-24) [i386-mingw32]
* Backport: 2.4: REQUIRED, 2.5: DONTNEED
----------------------------------------
Hello,

Running tests against ruby_2_2 branch, the following failures were detected (mingw-w64 4.7.2 32bits, GCC 4.7.2, Windows 7 x64):

~~~
TestRubyOptions#test_command_line_progname_nonascii [C:/Users/Luis/Code/ruby/ruby/test/ruby/test_rubyoptions.rb:719]:
[ruby-dev:48752] [Bug #10555].
<["?.rb"]> expected but was
<[]>.
---
<[]> expected but was
<["C:\\Users\\Luis\\Code\\oneclick\\rubyinstaller\\sandbox\\ruby21_build\\ruby.exe: Invalid argument -- ?.rb (LoadError)"]>.
~~~




-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>