Issue #14248 has been updated by naruse (Yui NARUSE).

Backport changed from 2.3: DONTNEED, 2.4: DONTNEED, 2.5: REQUIRED to 2.3: DONTNEED, 2.4: DONTNEED, 2.5: DONE

ruby_2_5 r61582 merged revision(s) 61500.

----------------------------------------
Bug #14248: configure fails to detect fd_mask type on OS X
https://bugs.ruby-lang.org/issues/14248#change-69162

* Author: drkaes (Stefan Kaes)
* Status: Closed
* Priority: Normal
* Assignee: 
* Target version: 
* ruby -v: ruby 2.5.0p0 (2017-12-25 revision 61468) [x86_64-darwin16]
* Backport: 2.3: DONTNEED, 2.4: DONTNEED, 2.5: DONE
----------------------------------------
When running configure on trunk and/or 2.5.0, configure fails to detect that the type fd_mask exists.

As a consequence, HAVE_RB_FD_INIT gets no set to 1, which leads to rb_fdset_t not being defined.

The bug was introduced with this commit: https://github.com/ruby/ruby/commit/3215b27a9abd8de793cf517f32d8901fd421eb1c





-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>