Issue #14243 has been updated by naruse (Yui NARUSE).

Backport changed from 2.3: DONTNEED, 2.4: DONTNEED, 2.5: REQUIRED to 2.3: DONTNEED, 2.4: DONTNEED, 2.5: DONE

ruby_2_5 r61581 merged revision(s) 61497.

----------------------------------------
Bug #14243: Comments inside ERB tags broken
https://bugs.ruby-lang.org/issues/14243#change-69161

* Author: jsc (Justin Collins)
* Status: Closed
* Priority: Normal
* Assignee: k0kubun (Takashi Kokubun)
* Target version: 
* ruby -v: ruby 2.5.0p0 (2017-12-25 revision 61468) [x86_64-linux]
* Backport: 2.3: DONTNEED, 2.4: DONTNEED, 2.5: DONE
----------------------------------------
A backwards-incompatible change was introduced with https://github.com/ruby/ruby/commit/abbfc048c5890e8017360bbc845062ea1585e155#diff-e1ea8366d3ac334deab7e0d25309be03

**Example:**

~~~ ruby
require "erb"
input = "<% # comment %>\n"
puts ERB.new(input).src
~~~


Before:

~~~
#coding:UTF-8
_erbout = +'';  # comment ; _erbout.<< -"\n"
; _erbout

~~~

After:

~~~
#coding:UTF-8
_erbout = +'';  # comment ; _erbout.<<(-"\n"
); _erbout
~~~

The generated code produces a syntax error due to introduction of parentheses around the arguments.

---Files--------------------------------
erb_test.rb (71 Bytes)


-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>