Issue #14236 has been updated by naruse (Yui NARUSE).

Backport changed from 2.3: DONTNEED, 2.4: DONTNEED, 2.5: REQUIRED to 2.3: DONTNEED, 2.4: DONTNEED, 2.5: DONE

ruby_2_5 r61580 merged revision(s) 61479.

----------------------------------------
Bug #14236: rb_autoload の可視性が変更された結果、特定のgemを使用するとランタイム時に落ちるようになった
https://bugs.ruby-lang.org/issues/14236#change-69160

* Author: hkdnet (Ko Sato)
* Status: Closed
* Priority: Normal
* Assignee: nobu (Nobuyoshi Nakada)
* Target version: 
* ruby -v: 2.5.0
* Backport: 2.3: DONTNEED, 2.4: DONTNEED, 2.5: DONE
----------------------------------------
nmコマンドから見える `rb_autoload` の可視性は従来 `T` でしたが、以下の変更により `t` になっています。
https://bugs.ruby-lang.org/projects/ruby-trunk/repository/revisions/57675

これにより以下の事象が発生しています。

stackprof v0.2.9 などの、 `rb_autoload` を使っている gem について、
インストール時のビルドはできるが実行時のダイナミックリンクで落ちる。

この事象はおそらく意図していないものではないかと思います。
手元では添付の patch で直ることを確認してます。

---Files--------------------------------
export-rb_autoload.patch (409 Bytes)


-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>