Issue #14227 has been reported by normalperson (Eric Wong).

----------------------------------------
Bug #14227: [PATCH] tool/rbinstall.rb: allow owner to have write permissions
https://bugs.ruby-lang.org/issues/14227

* Author: normalperson (Eric Wong)
* Status: Open
* Priority: Normal
* Assignee: 
* Target version: 
* ruby -v: 
* Backport: 2.3: REQUIRED, 2.4: REQUIRED
----------------------------------------
```
Denying ownership permissions to the owner seems bogus.

Oddly, this problem only manifests in the "ruby_2_4" branch when
installing bundled gems (rake and friends).  It does not happen
with "ruby_2_3" or "trunk", so it might be related to RubyGems
changes.

Steps to reproduce the problem:

  git clone git://80x24.org/mirrors/ruby -b ruby_2_4 rb24
  # git commit 6f1dc851e038575f5aec2a85ce7815b04c63dca2
  # ("merge revision(s) 57971: [Backport #13305]")
  cd rb24
  autoconf
  ./configure --prefix=$HOME/ruby-2.4 --disable-install-doc
  make -j8
  make update-download # downloads bundled gems
  make install # I get the following output:

  installing bundle gems:       /home/bb/ruby-2.4/lib/ruby/gems/2.4.0 (build_info, cache, doc, extensions, gems, specifications)
  /home/bb/rb24/lib/rubygems/package.rb:383:in `initialize': Permission denied @ rb_sysopen - /home/bb/ruby-2.4/lib/ruby/gems/2.4.0/gems/rake-12.0.0/.gitignore (Errno::EACCES)
    from /home/bb/rb24/lib/rubygems/package.rb:383:in `open'
    from /home/bb/rb24/lib/rubygems/package.rb:383:in `block (2 levels) in extract_tar_gz'
    from /home/bb/rb24/lib/rubygems/package/tar_reader.rb:65:in `each'
    from /home/bb/rb24/lib/rubygems/package.rb:365:in `block in extract_tar_gz'
    from /home/bb/rb24/lib/rubygems/package.rb:459:in `block in open_tar_gz'
    from /home/bb/rb24/lib/rubygems/package.rb:456:in `wrap'
    from /home/bb/rb24/lib/rubygems/package.rb:456:in `open_tar_gz'
    from /home/bb/rb24/lib/rubygems/package.rb:364:in `extract_tar_gz'
    from /home/bb/rb24/lib/rubygems/package.rb:345:in `block (2 levels) in extract_files'
    from /home/bb/rb24/lib/rubygems/package/tar_reader.rb:65:in `each'
    from /home/bb/rb24/lib/rubygems/package.rb:342:in `block in extract_files'
    from /home/bb/rb24/lib/rubygems/package/file_source.rb:30:in `open'
    from /home/bb/rb24/lib/rubygems/package/file_source.rb:30:in `with_read_io'
    from /home/bb/rb24/lib/rubygems/package.rb:339:in `extract_files'
    from /home/bb/rb24/lib/rubygems/installer.rb:784:in `extract_files'
    from /home/bb/rb24/lib/rubygems/installer.rb:302:in `install'
    from ./tool/rbinstall.rb:685:in `call'
    from ./tool/rbinstall.rb:685:in `block in <class:Installer>'
    from ./tool/rbinstall.rb:784:in `block (3 levels) in <main>'
    from /home/bb/rb24/lib/rubygems/user_interaction.rb:48:in `use_ui'
    from ./tool/rbinstall.rb:784:in `block (2 levels) in <main>'
    from ./tool/rbinstall.rb:780:in `each'
    from ./tool/rbinstall.rb:780:in `block in <main>'
    from ./tool/rbinstall.rb:822:in `block in <main>'
    from ./tool/rbinstall.rb:819:in `each'
    from ./tool/rbinstall.rb:819:in `<main>'
  uncommon.mk:284: recipe for target 'do-install-nodoc' failed
  make: *** [do-install-nodoc] Error 1
```


---Files--------------------------------
0001-tool-rbinstall.rb-allow-owner-to-have-write-permissi.patch (3.32 KB)


-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>