Greg.mpls / gmail.com wrote:
> I tried the attached patch to remove the :uplevel parameter
> for ruby < 2.5, and it passed on Appveyor & Travis for Ruby
> 2.4.  Assumes 2.10 never exists.  Most Ruby 2.3 versions had
> one failure.

Thanks, but as I stated up the thread I don't like version
guards since they clutter up the code.  Since `su' is never
called by default, I don't think it's worth the effort
(it'll only print out "{:uplevel => 1}" instead of raising).

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>