hsbt / ruby-lang.org wrote:
> Issue #14189 has been updated by hsbt (Hiroshi SHIBATA).
> 
> Status changed from Open to Assigned
> Assignee changed from hsbt (Hiroshi SHIBATA) to normalperson (Eric Wong)
> 
> >Personally, I do not like version guards, either.
> 
> A current implementation of webrick works with Ruby 2.3/2.4
> 
> https://api.travis-ci.org/v3/job/317931661/log.txt
> 
> But `lib/webrick/util.rb` is not supported Ruby 2.2. So, We could not guarantee to work webrick on Ruby 2.2 now.
> 
> https://bugs.ruby-lang.org/projects/ruby-trunk/repository/entry/lib/webrick/utils.rb#L199

Right.  The incompatibility I was referring to was the
`warn("...", uplevel: 1)` in `su' method;

but it is only warning, and maybe printing "{:uplevel => 1}" for
non-*nix platforms w/o `su' support is fine...

> >The thing is, ruby 2.4 and earlier do not have webrick installed as a
> >gem by default; it wasn't a default gem until 2.5. So "gem update"
> >for a 2.4 user should still never see this unless they willingly
> >had an ancient 1.3.1 installed.
> 
> Yes, We can provide a `webrick gem as default gems` after Ruby 2.5. 
> I have a plan to promote feature for default gems at RubyGems 2.8 or 3.0.
> 
> like this: ```$ gem install webrick --default -v 1.4.0``` with a Ruby 2.3 or 2.4
> 
> But it's still epic status.
> 
> Eric. How about a relaxing `required_ruby_version` of webrick to `>= 2.3.0`?
> (and bump version to 1.4.1)

Sure.  I'll leave the uplevel: keyword when people attempt `su';
but I guess it's a rarely-used method and nobody will care for the
noise on non-*nix...

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>