Issue #14189 has been updated by hsbt (Hiroshi SHIBATA).

Status changed from Open to Assigned
Assignee changed from hsbt (Hiroshi SHIBATA) to normalperson (Eric Wong)

>Personally, I do not like version guards, either.

A current implementation of webrick works with Ruby 2.3/2.4

https://api.travis-ci.org/v3/job/317931661/log.txt

But `lib/webrick/util.rb` is not supported Ruby 2.2. So, We could not guarantee to work webrick on Ruby 2.2 now.

https://bugs.ruby-lang.org/projects/ruby-trunk/repository/entry/lib/webrick/utils.rb#L199

>The thing is, ruby 2.4 and earlier do not have webrick installed as a
>gem by default; it wasn't a default gem until 2.5. So "gem update"
>for a 2.4 user should still never see this unless they willingly
>had an ancient 1.3.1 installed.

Yes, We can provide a `webrick gem as default gems` after Ruby 2.5. 
I have a plan to promote feature for default gems at RubyGems 2.8 or 3.0.

like this: ```$ gem install webrick --default -v 1.4.0``` with a Ruby 2.3 or 2.4

But it's still epic status.

Eric. How about a relaxing `required_ruby_version` of webrick to `>= 2.3.0`?
(and bump version to 1.4.1)


----------------------------------------
Bug #14189: Webrick 1.4.0. release requires unreleased ruby version 2.5.0dev
https://bugs.ruby-lang.org/issues/14189#change-68491

* Author: tb / panorama9.com (Thomas Balslv)
* Status: Assigned
* Priority: Normal
* Assignee: normalperson (Eric Wong)
* Target version: 
* ruby -v: 
* Backport: 2.3: UNKNOWN, 2.4: UNKNOWN
----------------------------------------
Hi Team!

We have just encountered a blocking bug in the Webrick gem version 1.4.0.
The gemspec is requiring an as yet unreleased version of ruby:

Gem::InstallError: webrick requires Ruby version >= 2.5.0dev.
An error occurred while installing webrick (1.4.0), and Bundler cannot continue.
Make sure that `gem install webrick -v '1.4.0'` succeeds before bundling.

https://github.com/ruby/ruby/blob/9cbb3bd1f2b05d59b6dd315ebdec295c2ced6c01/lib/webrick/webrick.gemspec#L13

It seems like a mixup happened between the branches with the 1.4.0 release.

Please fix ASAP.

Thanks!

Best regards, Thomas Balslv.



---Files--------------------------------
webrick_uplevel.patch (1.23 KB)


-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>