Issue #14189 has been updated by MSP-Greg (Greg L).


Eric,

Looking over 61155, it does seem rather odd to constrain updates to WEBrick to ruby >= 2.5 for two warnings.  Also, I believe WEBrick is the only gem affected by it.  Don't know what your thoughts are...

Also, re users not needing to install WEBrick, from over in the RubyInstaller repo, the first thing many people do with a Ruby install is `gem update` (which is why I asked a while ago about a digest gem).  If WEBrick can maintain compatibility with 2.3 forward, it would probably help a lot of support people...

shevegen (Robert A. Heiler) wrote:
> By the way, perhaps webrick should be added to "bundled_gems" too like many other distributed gems:

I believe it's a default gem, which basically means it can't be uninstalled with RubyGems, but it can be updated.  FYI, default gems have their code in the ruby repo, bundled gems are added by the build process.

Thanks, Greg

----------------------------------------
Bug #14189: Webrick 1.4.0. release requires unreleased ruby version 2.5.0dev
https://bugs.ruby-lang.org/issues/14189#change-68455

* Author: tb / panorama9.com (Thomas Balslv)
* Status: Open
* Priority: Normal
* Assignee: 
* Target version: 
* ruby -v: 
* Backport: 2.3: UNKNOWN, 2.4: UNKNOWN
----------------------------------------
Hi Team!

We have just encountered a blocking bug in the Webrick gem version 1.4.0.
The gemspec is requiring an as yet unreleased version of ruby:

Gem::InstallError: webrick requires Ruby version >= 2.5.0dev.
An error occurred while installing webrick (1.4.0), and Bundler cannot continue.
Make sure that `gem install webrick -v '1.4.0'` succeeds before bundling.

https://github.com/ruby/ruby/blob/9cbb3bd1f2b05d59b6dd315ebdec295c2ced6c01/lib/webrick/webrick.gemspec#L13

It seems like a mixup happened between the branches with the 1.4.0 release.

Please fix ASAP.

Thanks!

Best regards, Thomas Balslv.





-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>