shevegen / gmail.com wrote:
> Good catch. 
> 
> I guess the japanese hackers all happily use ruby 2.5.x already. :)

/me is not Japanese, but yes, I mainly use 2.5.x

> 2.4.3 was recently released. Guess it is a stable variant on the
> 2.4.x branch.
> 
> Webrick at https://rubygems.org/gems/webrick has the ">= 2.5.0dev"
> tag, and presently 2.5.0dev is not available. If there are no 
> breaking changes, perhaps the 2.4.x branch works fine and webrick
> could default to 2.4.x. for the time being - that should solve 
> the issue for now.

Oops, I inherited this from hsbt.  I'm not sure about the
versioning, but it looks like we started using 2.5.0dev
features recently in:

	r61155  Add uplevel keyword to Kernel#warn and use it

I suppose we could revert that change and see how it does
on 2.4...


Thomas: do you actually need to install or declare webrick
as a dependency somewhere?  It's always been bundled with Ruby
so I don't think you need to worry about declaring it as a
dependency (and the 1.3.1 on rubygems.org was way out of date).

If you're on ruby 2.4 or earlier, use the bundled one instead
what's on rubygems.org

> By the way, perhaps webrick should be added to "bundled_gems" too
> like many other distributed gems:
> 
>     https://github.com/ruby/ruby/blob/trunk/gems/bundled_gems

*shrug* I'll let hsbt answer this; can't say I know too much
about gem bundling stuff.

> ----------------------------------------
> Bug #14189: Webrick 1.4.0. release requires unreleased ruby version 2.5.0dev
> https://bugs.ruby-lang.org/issues/14189#change-68449
> 
> * Author: tb / panorama9.com (Thomas Balslv)

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>